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Abstract: This workshop focuses on the functions and data analysis tools
of Microsoft Excel. Topics included are the function wizard,
function definitions, and the data analysis tool pack.

Contents
[} 1o e {8 Tex 1 o] o RO PP PRP 3
ODJECOHIVES ...ttt e e e e e e e e e e e e e e 3
L =T Y0 (U= (= S 3
Related Training Available from ACS.........oo it 3
T 11T < 4
T e (o] A =T o L 5
Sample Functions in the Function Wizard....................... 7
Add-in Commands and FUNCHONS.........c.oeiiiiiiiiiiiiiiiiiiiiieiieeeieeeeeeeve e eeeeeeeeeeneeenneanne 9
Loading @N @dd-iN ......eeiiiiiiiei e 9
(W] 0] o =To [ Ta T =T 1= To [ o SRR 10
Data ANalYSIS TOOIS ....iiiiiieeeei e e e e e e e 10
[ 1153 (oo | =1 o  H PO PP PPPR S PPPPP 10
(O] o 1170 g F=1 IS0 ¢ o USSP PPRERPR 13
Analyzing Data with the Pivot Table...........ccoooiiii e 14
AITAY FOIMUIS ...t e e e e e s 16

© 2003 University of Kansas. All rights reserved


http://www.ku.edu/acs

ACS Computer Training
Functions & Data Analysis Tools

Getting Additional HEelp .....cccooiiieieee e 18

Academic Computing Services -2- © 2003 The University of Kansas
A Division of Information Services



ACS Computer Training
Functions & Data Analysis Tools

Introduction

The Excel software package consists of three basic parts: its electronic spreadsheet,
graphics, and database utilities. Using a single set of data, these separate utilities can
work together or individually. This workshop concentrates on defining Excel functions,
using the function wizard, and using the Data Analysis Toolpak.

Objectives

The goal of this workshop is to introduce participants to the more complex features of
Excel. After today's workshop participants will be able to:

e define terms used in creating functions

e create and edit a function using the Function Wizard
e identify add-in functions

e perform data analysis using Data Analysis Tools

e create a formula with the Conditional Sum wizard

e learn to trouble shooting a formula

Prerequisites

It is assumed that the participants in this workshop have either taken the Excel: Data
Management workshop or have equivalent skills.

Related Training Available from ACS

All workshops offered by Academic Computing Services (ACS), a division of
Information Services, are free to KU students, staff, faculty, and approved affiliates. The
general public is also welcome to most workshops, but some ACS workshops require a

registration fee for them.

To learn more about or register for workshops, receive automatic announcements of
upcoming workshops, and track workshops you’ve registered for and have attended, visit
the ACS Web site at www.ku.edu/acs/train. You can also check our online schedule at
www.ku.edu/acs/schedule for a list of class offerings and their availability. For further
workshop related questions, please email training@ku.edu.
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Definitions

Term Definition

Formula | A formula is an equation that analyzes data on your worksheet. Formulas
perform calculations such as addition or multiplication; formulas can also
combine values. In Excel, all formulas begin with an equal sign (=) and are
followed by the data the formula calculates.

Formula Formula syntax is the structure or order of the formula elements. All
syntax formulas begin with an equal sign (=) followed by operands (the data to be
calculated) and the operators. Operands can be values that don't change
(constants), a range reference, a label, a name, or a worksheet function.

Formula | The formula bar is an area located at the top of the worksheet window that

bar is used to enter or edit values or formulas in cells or charts. The formula
bar displays the constant value or formula in the active cell. To display or
hide the formula bar, click Formula Bar on the View menu

Order of | Formulas are calculated left to right, using order of precedence, unless the
precedence | use of parentheses changes the order of calculation.

Example: =10+10"4 or =(10+10)*4

Excel performs operations in the order shown in the following table. If a
formula contains operators with the same order of precedence, Excel
evaluates the operators from left to right. For example, if you enter the
formula, 7 + 7 — 5, the calculation is performed left to right since both +
and — have the same precedence. If you enter the formula, 7 +7 * 5,
Excel performs the multiplication first since * has a higher precedence
than +.

To change the order of evaluation, enclose the part of the formula to be
calculated first in parentheses.

Operator | Description
- (colon), (comma) (single space) | Reference operators
— | Negation (as in —1)
% | Percent
A | Exponentiation
*and / | Multiplication and division
+ and - | Addition and subtraction

& | String Concatenation

=, <, >, <=, >=, <> | Comparison
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Term Definition

Function | A function is a predefined formula that performs calculations by using
specific values in a particular order. The values used in the function are
called arguments (see below) and these arguments must appear in a
specific order. For example, the AVERAGE function calculates the
average of several values or arguments.

Arguments | Arguments can be numbers, text, logical values, such as TRUE or FALSE,
arrays, error values such as #N/A, or cell references. The argument you
designate must produce a valid value for that argument. Arguments can
also be constants, formulas, or other functions.

Function | The syntax of a function begins with the function name, followed by an

syntax opening parenthesis, the arguments for the function separated by
commas, and a closing parenthesis. If the function starts a formula, an
equal sign (=) displays before the function name.

Example: SUM(D2..F8)

In the above example, the function name is "SUM" and the argument for
the function is the range "D2..F8".

Formula | The formula palette is a tool that helps you create or edit a formula and
palette also provides information about functions and their arguments. The palette
appears below the formula bar when you click the Edit Formula button on
the formula bar (=) or the Paste Function button (E) on the Standard
toolbar.

Add-ins Add-ins are programs that provide optional Excel commands and features.
To make add-ins available, you must first install the add-in and then “load”
it. Once an add-in is loaded, it is available within Excel. Add-ins might
place additional commands on Excel menus.

Add-ins use a lot of memory so unload add-ins you do not use often.
Unloading an add-in only removes its features and commands from Excel.
Unloading does not delete the add-in since the files are still available and
can be reloaded since the add-in remains on your computer.

A list of all add-ins automatically installed when you install Excel are
available in the Help menu. Select Help and click Contents and Index.
Enter “add-in programs, installing” and select “Components installed with
Microsoft Excel.”

You can also use Visual Basic programs as custom add-ins

The Function Wizard

The Function Wizards are designed to help provide the necessary arguments and
descriptions for the various Excel functions.
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To access the Function Wizard,

1. Select the cell in which you want the results of the function to display.

2. Click the Function Wizard button on the Standard toolbar (&) or select Function...

from the Insert menu

3. Select a function category from the list on the left of the Paste Function dialog box. A
list of function names (grouped by category) displays on the right. To view all

functions, click All on the Category list.

Function categary: Function narme;

Most Pecently Usec couNt T
All T |COUMNTBLANE

Financial COUNTA

Date & Time TYPE

Math & Trig TIME

Statistical COUNTIF

Lookup & Reference IF

Database CELL

Text |5

Logical AMERAGE

Infor mation LI LI

COUNT {valuel valueZ,...}

Counts the number of cells that contain numbers and numbers within the
list of arguments.

El ok I Cancel

Paste Function dialog box

4. Double-click the function name listed on the right and the Function Palette displays.
The Function Palette displays input boxes and explanations to provide the necessary
function arguments. The palette also displays sample function results.

~COUNT

value1 [ | - {120}
Value2| 3’ =

=1
Counts the nurmber of cells that contain numbers and numbers within the list of arguments.

Valuel: valuel,valug2,... are 1 o 30 argurments that can contain or refer to a
variety of different types of data, but only numbers are counted.

@ | Formula result =1 0K | Cancel |

Function input and argument dialog box

5. Enter the necessary arguments in the input boxes. To select ranges on your
worksheet, click E{ beside the appropriate dialog box. Excel hides the Function
Palette so that you can use your mouse to manually select the correct range(s). To
return to the Function Palette, click E{ or press Return.

6. Click OK when you have finished entering arguments.

Academic Computing Services
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Sample Functions in the Function Wizard

During the workshop, the following functions demonstrate the Function Wizard and Paste
Function dialog box.

CONCATENATE

The Concatenate function joins several text strings into one text string. The "&" operator
can be used instead of CONCATENATE to join text items.

Syntax
CONCATENATE (textl,text2,...)

Arguments

textl, text2, ... are 1 to 30 text items that will be joined into a single item. The
text items can be text strings, numbers, or single-cell references.

Notes

CONCATENATE ("Academic ", "Computing ", "Services") is equivalent to
"Academic Computing Services." If cell A2 contains "Academic " and B2
contains "Computing " then CONCATENATE (A2,B2, "Services") is equivalent
to "Academic Computing Services."

COUNT
Counts the number of cells that contain numbers and numbers within the list of
arguments.
Syntax
COUNT(valuel,value2, ...)
Arguments
valuel, value2, ... are 1 to 30 arguments that can contain or refer to a variety of
different types of data, but only numbers are counted.
COUNTA

Counts the number of cells that are not empty and the values within the list of arguments.
Use COUNTA to count the number of cells that contain data in a range or array.

Syntax
COUNTA(valuel,value2, ...)

Arguments

valuel, value2, ... are 1 to 30 arguments representing the values you want to
count. In this case, a value is any type of information, including empty text ("")
but not including empty cells.
Academic Computing Services -7- © 2003 The University of Kansas
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COUNTBLANK

Counts empty cells in a specified range of cells. Cells with formulas that return
(empty text) are also counted. Cells with zero values are not counted.

nn

Syntax
COUNTBLANK(range)

Arguments

Range is the range of cells where you want to identify blank cells.

COUNTIF

Counts the number of cells within a range that meet the given criteria

Syntax
COUNTIF(range, criteria)

Arguments
e Range is the range of cells where you want to count cells.

o  (Criteria are the forms of a number, expression, or text that will be counted.
For example, criteria can be expressed as 123456, "123456", ">123456",
"enrolled".

VLOOKUP

In general, lookup functions are used to lookup data in one list and return a corresponding
value. Vlookup (vertical lookup) is one of several lookup functions, but since data is
generally organized in columns, vlookup is used frequently.

Syntax
VLOOKUP(lookup value, table array, col index num, range lookup)

Arguments

e lookup_ wvalue is the value to be found in the first column of the table array.
The lookup value can be a value, a reference, or a text string.

e Table array is the table of information in which data is looked up. If you
create a range name like List or Sales Table, it is easy to copy the function
without losing your reference to the table range. Otherwise you will need to
use absolute addressing in specifying the table. The values in the first
column of table array can be text, numbers, or logical values.

e Col _index_num is the column number in the table array from which the
matching value must be returned. For example, a col_index num of 2 returns
the value in the second column in table array. If col index num is less than
1, VLOOKUP returns the #VALUE! error value; if col _index num is greater
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than the number of columns in table array, VLOOKUP returns the #REF!
error value.

e Range lookup is a logical value that specifies whether you want VLOOKUP
to find an exact match or an approximate match. If the range lookup
argument is omitted (TRUE), an approximate match is returned. If an exact
match is not found, the next largest value that is less than lookup value is
returned. If FALSE, VLOOKUP will find an exact match and if an exact
match is not found, the error value #N/A 1is returned.

Notes

If range lookup is TRUE, the values in the first column of table array must be
placed in ascending order, otherwise VLOOKUP may not give the correct value.
If range lookup is FALSE, table array does not need to be sorted.

Example
A B C 1] E E [E] H I
i Table_aray lpokup_vabue
2 Sales Level Bonus Rate Fep  Sales  Bonus
3 £0.00 0% Fred | 23000 |=VLOQKUR(ES, table_array, 2, TRUE)
4 10,000 4% Mary 24000 0.06
5 $20,000 %, Beth 16000 0.04
§ $30,000 2% Jaohin 25000 0.08
7 40,000 12% Dave 32000 0.0
g Janet 30000 0.0
:

Using the VLOOKUP function

Using the above image as an example, the VLOOKUP formula is placed in the
Bonus column in the table on the right.

The Sales column is the lookup value and, from the table on the left, the Sales
Level column and the Bonus Rate columns comprise the table array since you
want to determine what rate should be paid for corresponding sales.

The col_index num is 2 since the rate that you want to report is in the second
column of the table array. The range lookup is TRUE because we don't need to
match the sales exactly. You can omit the range lookup or type TRUE. Note:
Since the Sales value does not match the Sales Level exactly, Table B must be
sorted in ascending values.

Add-in Commands and Functions

An Add-in is a command or function that, once loaded, appears to be a part of the Excel
program. Add-in commands or functions may be user-created macros or may be the add-
ins included with the Excel program. Some Excel add-ins are automatically loaded when
Excel is installed; the user loads others. Not all add-ins are automatically loaded because
add-ins use a lot of memory.

Loading an add-in

Once an add-in is loaded, it is always available until you unload it. To load an add-in

Academic Computing Services -9- © 2003 The University of Kansas
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1. On the Tools menu, click Add-Ins.

2. Inthe Add-Ins available box, click the check box next to the add-in you want to load.
If the add-in you want to use is not listed in the Add-Ins available box, click Browse,
and then locate the add-in. If the add-in is not installed on your computer, you must
install it.

3. Click OK.

Unloading an add-in

Unloading add-ins that you don’t use can save memory since all loaded add-ins are
always loaded into memory when Excel is opened.

1. On the Tools menu, click Add-Ins.

2. Inthe Add-Ins available box, clear the check box next to the add-in you want to
unload.

3. Click OK.

When you unload an add-in, the add-in macro is not deleted from your computer.

Data Analysis Tools

The Analysis Tools are Excel Add-ins and take a few seconds to load when the command
is first selected. The Analysis Tools command on the Options menu is available only if
the Analysis ToolPak is installed. The Analysis Tools are one of several Add-ins
available within Excel. Analysis Tools involve the collection, organization, and
interpretation of numeric data.

Histogram
A histogram is an analysis tool that consolidates data into a range of numeric intervals to
show how frequently the range contains similar values.

Setting up the data

A histogram counts how many of the values in a range (input range) fall within specified
numeric intervals (bin range). For example, in a group of people, you could determine
the distribution of ages within age categories.

You need to setup your worksheet before running the Histogram Data Analysis tool. You
need to determine the following:

e The Input range or the range of values to analyze.

e The Bin range or the range of cells that contain a set of boundary values. (See
below.) The Bin Range is optional.

e The Output range or an area to display the histogram.

Input Range

In the example below, the ages column is the input range since this is the
column of data to analyze.

Academic Computing Services -10- © 2003 The University of Kansas
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A B A
1 | Names Ages 1 | Bin
2 Brown 23 220
3 Zeller 16 3|30
4 Smith 45
5 McGrath 33 4|40
6 | Jefferson | 29 5|50
7 Jones 55 6 | 60
8 | Whitehead | 48
9 Mancusi 21
10 | Yashima 38
11 | Winters 19
12 Maher 51
13 | Griffin 28

Bin Range

In the example above, the bin range contains the age intervals. When setting up a
histogram, make sure the intervals for the bin range are specified in ascending
order.

Output Range

The results of the distribution can be placed in an area on the current worksheet,
on another worksheet within the same workbook, or in another workbook.

Creating the Histogram

Before accessing the Histogram Analysis tool, make sure your worksheet is setup
properly. See Setting up the data above.

To create a histogram:

1. Choose Analysis Tool from the Tools menu

2. Select Histogram from the Data Analysis list box.
3. Click OK to display Histogram dialog box.

Academic Computing Services -11- © 2003 The University of Kansas
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Histogram m
~Input
Ol |
Input Range: || y
Cancel
Bin Range: I }I 4|
Hel
" Labels il
~Output options

= Qutput Range:
" Mew \Warksheet Ply:
" mew YWorkbook

|$L$3

L]

I~ Pareto (sorted histagram)
r Cumulative Percentage
™ Chart Output

The Histogram dialog box

4. Enter the range of cells to analyze in the Input Range: input box.

5. Enter the Bin range in the Bin Range: input box. If you omit the bin range, Excel
creates a set of evenly distributed bins between the data's minimum and maximum
values.

6. Specify the output range. See Output options below

Output Options

Output Range

Enter the reference for the upper-left cell of the output table. The size of the output area
is automatically determined and Excel displays a message if the output table might
overwrite existing data.

New Worksheet Ply

Click to insert a new worksheet in the current workbook and paste the results starting at
cell Al of the new worksheet. You can name the worksheet by typing a name in the input
area after selecting New Worksheet Ply.

New Workbook

Click to create a new workbook and paste the results on a new worksheet in the new
workbook.

Other Histogram Options

Labels

Select Labels if the first row or column of your input range contains labels. Clear this
check box if your input range has no labels; Excel generates appropriate data labels for
the output table.

Academic Computing Services -12- © 2003 The University of Kansas
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Pareto

If the Pareto box is checked, the output data displays in descending frequency order in the
output table.

Cumulative Percentages

If the Cumulative Percentages box is checked, Excel generates an output table column for
cumulative percentages. Leave unchecked to omit the cumulative percentages.

Chart Output
Select Chart Output to generate an embedded histogram chart with the output table.

Conditional Sum

Use the Conditional Sum Wizard to summarize values in a list based on specific
conditions. The Conditional Sum Wizard can help you determine the number of people
that meet a certain criteria. In the example below, the conditional sum function can
determine how many people are on academic probation that transferred from other
schools. In this example, there are two criteria that need to be defined and then a sum of
those who meet both.

A B Cc
Name | Status Change of School
Jim Enrolled Transfer

Mary Probation KU - College
Fred Enrolled KU - Business
5 Alice Enrolled Transfer

To Start the wizard:

(W N |-

1. Click a cell within the table or list.
2. On the Tools menu, point to Wizard, and then click Conditional Sum.

3. The Conditional Sum Wizard is an add-in program. If the Conditional Sum
command is not on the Wizard submenu, install and load the wizard. (See Add-in
commands and Functions above.)

4. Enter the information requested. (See the image on the next page) Use the pull-
down menus to select available options for the Column to Sum. Also use pull-down
menus to determine the criteria of the data to sum. Click the Add Condition button to
add criteria to the list; you can define more than one criterion.

5. After all selections are complete, click Finish on the last dialog box.

Academic Computing Services -13- © 2003 The University of Kansas
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Conditional Sum Wizard - Step 2 of 4 m

Which colummn contains the values to sum? Select the column
lakal

Column & sum: | change of school =]

Mext, select a colurmn you want to evaluate, and then type or select a
value to compare with data in that column.

Column; Is: This value;

Change of school j I = ﬂl fransfer ﬂ

Add Condition I | Femaeve Eomnaitinm |

Change of school=transfer

@| Cancel | < Back | Mext = I Fimish |

The Conditional Sum Wizard

Analyzing Data with the Pivot Table

A PivotTable is an interactive table that summarizes, or cross-tabulates, large amounts of
data. You can rotate rows and columns to view various summaries of data. You can also
filter data by displaying different pages or display the details for areas of interest.

The PivotTable summarizes data by using a summary function that you specify, such as
Sum, Count, or Average. You can include subtotals and grand totals automatically, or use
your own formulas by adding calculated fields and items.

A Pivot Table wizard provides help in creating pivot tables.

Before creating a Pivot Table
Before starting the Pivot Table wizard,

1. Your worksheet data must be organized in a list or database format. (See the Excel:
Data Management handout.)

2. Place your cursor inside the list.

Remove all subtotals created with Data->Subtotals command since grand and
subtotals are automatically created as part of the pivot table. (See the Excel: Data
Management outline.)

Creating a Pivot Table

Before beginning the Pivot Table Wizard, make sure you have followed the instructions
above.

1. Select Pivot Table Report from the Data menu. The first step of the Wizard displays.

2. Identify the location of your Pivot Table data source. The default setting is an Excel
list or database on your current worksheet. Click Next.
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3.

9.

Select the range of cells that comprise your list. If your cursor is inside the list or
database area, Excel selects the data automatically. You can redefine the list if

necessary by using your mouse to select the data source and then press Enter to return
to the dialog box.

Click Next.
A sample pivot table layout displays.

PivotTable Wizard - Step 3 of 4 [ 2] x]

L Construct your PivotTable by dragging
=)

the field buttons on the right to the

diagrarm on the left.

[ pace | COLUMN
ROW DATA

@ Cancel | < pack | Mesxt = Einish |

The Pivot Table Wizard

Any column labels on your list are displayed as buttons and referred to as fields.
Each field can be placed in one of four parts of the pivot table.

Row: Any field placed in the Row area becomes a row label.

Column: Any field placed in the column area becomes a column label.

Data: Any numeric field placed in the Data area is summarized (sum, average, etc.).
Page: Any field you want to use as a filter is placed the Page area.

To place a field in the pivot table, drag the field name to the appropriate area.

Click Next when the layout is complete.

Select the location for the pivot table. The default is to place the table on a new
worksheet.

You can designate an area of an existing worksheet if you select Existing Worksheet
and then use your mouse to identify the upper left corner of the Pivot Table.

Click Finish

Editing the Pivot Table

You can edit and format many components of the Pivot Table. To select areas of the
Pivot Table, use the following table as a guide.

Clicking... Selects
Row Field All row labels
Row item All item data
Academic Computing Services -15- © 2003 The University of Kansas
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Column field All column labels
Column item All item data
Summary label Entire table

Grand Total label Column or row totals

Table Components and Selection

Double-click the row or column fields to display the Pivot Field dialog box. If the above
methods do not select, from the PivotTable tool bar (see below), click Select and Enable

Selection.
Pivot Table Toolbar
When a Pivot Table is displayed on a worksheet, the Pivot Table toolbar automatically
displays.
FivotTable
PiyotTable - L:4]
¢ » = = |0 [ & =
The Pivot Table toolbar

Click [i#l to access the original Pivot Table wizard and | to access the Pivot Table Field
dialog box. Both these buttons can be used to change the Pivot Table data display and
values.

Deleting the Pivot Table
To delete a Pivot Table

1. On the PivotTable menu of the PivotTable toolbar, point to Select and select Enable
Selection.

2. Click a cell in the PivotTable.
3. On the PivotTable toolbar, point to Select and then click Entire Table.

4. On the Edit menu, point to Clear, and then click All. When you delete a PivotTable,
the source data is not deleted or changed.

Array Formulas

An array formula is a formula that performs multiple calculations and returns either a
single result or multiple results. Array formulas act on two or more sets of values known
as array arguments.

Each array argument must have the same number of rows and columns. You create array
formulas the same way that you create basic, single-value formulas.

Entering an array formula
To enter an array formula,

1. Select the cell or cells that will contain the formula.
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2.
3.

Enter the formula.

Press CTRL+SHIFT+ENTER to enter the formula within the cell. Brackets {}
display around the entire formula, including the equal sign.

If you want only a single result, Excel may need to perform several calculations to
generate that result.

Troubleshoot errors in formulas

If you have problems when creating functions, check the following to trouble-shoot your
formulas.

Double-click on the cell that contains the formula to edit the formula. The worksheet
ranges and the corresponding arguments within the formula display in colors to
clearly define you formula arguments.

Parentheses are part of a matching pair. When you create a formula, Excel displays
parentheses in color as they are entered.

Make sure you use the correct range operator when you refer to a range of cells.
When you refer to a range of cells, use a colon (:) to separate the reference to the first
cell in the range and the reference to the last cell in the range.

Make sure you have entered all arguments that are required and not any extras. Some
functions have required arguments.

You can enter, or nest, no more than seven levels of functions within a function.

If the name of a workbook or a worksheet you refer to contains a non-alphabetic
character, you must enclose the name within single quotation marks.

Make sure each external reference contains a workbook name and the path to the
workbook.

Do not format numbers as you enter them in formulas. For example, even if the value
you want to enter is $1,000, enter 1000 in the formula.
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Getting Additional Help

ACS provides consulting and Q&A help in a variety of ways:

785/864-0200
question@ku.edu
www.ku.edu/acs/help

Last Update: 02/14/2003
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