Spatial Aggregation Lab

GIS and Public health Class, Revised April 2, 2009

Instructor: Thomas Talbot, tot01@health.state.ny.us

Files needed to perform lab:


Health outcome and sociodemographic MapInfo Files: 
zip06_simlbw2

Health outcome and sociodemographic shape files: 

zip06_simlbw2_region


SAS Contiguity program: 




births contiguity shapefile.sas  


SAS Aggregation program:  




sim_aggregate_births.sas


These files are stored i:\faculty\TomTalbot\aggregationlab folder
Save the entire aggregationlab folder with all these files to your flashdrive.

Software: 
SAS 9.1, MapInfo,  

Optional Excel can be use to calculate correlations (R2)   

Aggregation Lab Objective

In this lab you will learn a new tool developed by the NYSDOH which aggregates small areas into larger areas until a user defined number of cases and/or population is reached. You will also learn how changing the spatial scale of your data may impact map displays and measures of association.  This phenomenon is commonly referred by geographers as the Modifiable Are Unit Problem (MAUP)
The tool  is designed to spatially aggregate data in order to reduce the random fluctuations in the disease rates.  A general description of how aggregation is done was presented in the previous class lecture. In this lab exercise you will actually use some simulated data at the ZIP code level and aggregate the data at two different population scales.  You will then be asked to compare health outcome rates with socio-demographic variables to see how the correlation changes with the change in scale. 

Please read over the homework assignment on page 10 prior starting the lab so you know what is expected. 

The data

The health outcome data you will be using includes simulated birth data which includes the total number of singleton births and the number of low birth weight births by ZIP Code over a 5 year period. 

This data also includes information on educational attainment, race and the number of children living in poverty for each ZIP Code.  The data dictionary for the data you will be using is in appendix 3.
SAS Tools
You will use two SAS programs to complete the aggregation in SAS. You will bring the results of these programs into a GIS package and make choropleth maps of low birth weight standard incidence ratios (SIRs). The first program is a contiguity program: births contiguity shapefile.sas.  For each ZIP code the program determines all contiguous neighbors.  The second program sim_aggregate_births.sas determines which ZIP codes are aggregated together so that each region has a user-defined minimum number of births. Printout of the SAS programs are provided in appendices 1 and 2.
Contiguity SAS Program

Edit the contiguity program births contiguity shapefile.sas which is stored on your flash drive program where it is marked in red italics in Appendix 1. You can edit the program either in SAS or a text editor such as notepad.  You will set the libname in SAS to a folder on your flashdrive.  Refer to the SAS program printouts attached to this lab (Appendix 1).
You will also need to specify the name and location of your input file zip06_simlbw2_region.shp which should also be stored on your flash drive.

Run the program in SAS by clicking Run -> Submit or by clicking the ‘running man’ icon [image: image21.png]Update Column
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 .  The program should output a SAS data file zcont to your flash drive.

The contiguity program (births contiguity shapefile.sas) outputs a SAS data set which looks something like the table below. To see this table you can double click on the zcont.sas7bdat file on your flashdrive.
The contiguous neighbors of ZIP code 10001 are 10016,10018,10010,10011. Some ZIP codes such as 06390 are islands so they do not have contiguous ZIP Codes. If these islands need to be merged later, the aggregation program locates the closest ZIP code by calculating the distances between ZIP code centroids. 
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SAS Aggregation Program

Next you will run a program sim_aggregate_births.sas which will determine which ZIP codes are aggregated together.  Each ZIP Code is assigned a region code (newregion).

In order to run the program you will need to edit this SAS program in similar way to how you edited the births contiguity shapefile.sas program. Edit the program where it is marked in italics in Appendix 2.  You will set the libname in SAS to a folder on your flashdrive. Refer to the SAS program printouts attached to this lab (Appendix 2).
a. In the aggregation program change the libname statement to list a directory on your flashdrive where you stored the results of the contiguity program. 

b. You will also type in the name of your dbf output file. Make sure you list the flashdrive directory as well as the name of the file.  For example if you are running the program with an aggregation of three hundred births minimum you might have an output file name that is f:\aggregationlab\talbot300.dbf. 

c. You will also need to set the mincriteria to 300 to aggregate the ZIP codes into areas where each area has a minimum of 300 births.

d. Run the program in SAS.  Check the SAS Log to see if there are any error messages (it is a good idea to clear your log window before you rerun programs).  If the program runs correctly you should get a SAS map similar to the map below.  The program also provides the frequency counts of how many births are in each aggregated region.

e. Redo steps a-d to create another dbf file with a minimum number of births to 600 (mincriteria = 600) and a different output file name than you used for aggregation at 300 births. If you forget to change the output file name, the 600 births file will overwrite the 300 births file. Remember to check the SAS Error Log.
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Combining Objects and Displaying New Aggregated Regions

After you have run the aggregation program at both scales, you should have two output files: yourname300 and yourname600  (you may have saved them as something else).

In order to see how ZIP codes aggregated and to look at population data at this scale, you need to bring the files back into Mapinfo. These files are saved as .dbf files located in the directory that you assigned as the libname.

Open Mapinfo. Open the two DBF files (remember to change the file type to “dbase DBF (*.dbf)”).

You will notice that only a browser window opens. The DBF files are both unmappable. In order to visualize the regions in a map window, you need to join it with a map that has ZIP code regions. We will use the original ZIP code file: zip06_simlbw2. Open the file from the directory you saved it in.

To assign the regions from the old file to the new aggregated file, you need to run an SQL Select. 

Query-> SQL Select

Add one aggregated file (simbirths300pw or simbirths600pw) and zip06_simlbw2 to the ‘from tables’ section. Use ZIP code fields to join the tables in the ‘where condition’ section. Save the query as a table that you will recognize, such as ‘new’. Click ‘OK’
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The result is a new mappable table that has all variables from both tables. However, you will see that the map appears no different from the original ZIP code file. To see how the ZIPs aggregated, you need to combine objects.

Save a copy of the new table as something you recognize. 
File-> Save copy as-> (Choose your new table)-> click ‘Save as’-> (Save as something you recognize, I used ‘Talbot1’, it would be wise to add ‘300’ or ‘600’ to distinguish between scales of aggregation)

Open the table you just saved.

File->Open->Talbot1

Next, you will combine objects by the new aggregated areas (variable ‘newregion’).

Table->Combine Objects using column

[image: image1.bmp]
Choose your new table and choose to group objects by column ‘newregion’ then click ‘Next’.
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Make sure that the table used is your new table, then click ‘Create’.
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A new table structure window will pop up. Do not change the table structure. Click ‘Create’.

Mapinfo will prompt you to save the new file with combined objects. Save it as something you recognize; I used ‘talbot2’.
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The data aggregation window that pops up next will allow you to choose how you want objects to combine. Check to make sure all race, ethnicity, poverty, education, simbir0105, and simlbw0105 variables are listed as ‘sum’ under ‘method’ (See Appendix 3 for Data Dictionary). Click ‘OK’.
Mapinfo will combine the objects and then show a map of the new regions you created. You can deselect the regions to get a better view by clicking in white space outside of NYS or by hitting the ‘deselect’ button [image: image5.bmp] .

To see how your aggregated map compares to the old ZIP code map, open zip06_simlbw2 in the new map window.

Map-> Layer control-> Add-> zip06_simlbw2-> Click ‘Add’

Highlight zip06_simlbw2-> click ‘Display’-> style override-> Click the picture of the polygon-> Change the border color to a different color than the new region map-> click ‘OK’ -> click ‘OK’
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                 You will end up with a map that looks something like:
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The objects outlined in red are the new aggregated areas. The objects outlined in blue are the original ZIP code areas. You can use the ‘info’ tool [image: image7.bmp]  to see how many births were in each original ZIP code and then how many births are in the new aggregated areas.

Undergo the same steps for the map aggregated to the 600 births scale (from SQL select through looking at the aggregated objects a map browser). Open all three region files (original zips, 300, and 600 births) in one map browser and see how they differ.

Calculating Proportions and Standardized Incidence Ratios:

To complete the maps that will be turned in, you will need to calculate proportions and standardized incidence ratios (SIR). Add three new fields to both aggregated (300 and 600 births) tables: prop_black, prop_pov, and SIR. Format the new fields as Decimal 12, 4. Add a new SIR field to the original ZIP code file (zip06_simlbw2).
Table -> Maintenance -> Table Structure -> talbot2 -> Add field
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You will notice that there are two fields for every zip, county, birth, race, ethnicity, poverty, and education category. If you have not done so already, delete the duplicate fields, which you can identify by the ‘_2’ at the end of the variable name. Use the data dictionary in Appendix 4 to understand what the variables mean.
Remove: lths_2, hsg_2, upov0_4_2, opov0_4_2, simbir0105_2, simlbw0105_2, A_00_04_2, AI_00_04_2, B_00_04_2, H_00_04_2, M_00_04_2, NH_00_04_2, PI_00_04_2, total0_4_2, W_00_04_2, zip06_2, county_2

First, calculate the proportion of the population of 0-4 year olds that are black (B_00_04), then of the population of 0-4 year olds that are living under the poverty level (upov0_4).

Table-> Update column -> Talbot2
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Update ‘prop_black’ from the table you are using. You can type in the value or use the assist option to select columns. Calculate the proportion by dividing the black population count by the total population (total0_4).

Do the same to update prop_pov. (prop_pov= upov0_4/total0_4)
Make sure to add these fields to both the 300 and 600 scale aggregation tables.

To calculate the SIR, we need observed and expected values. 

SIRi=observed incidence of LBW/expected incidence of LBW = (ci/ni)/(C/N)

ci= number of lbw babies in region ni=number of births in specific region

C=total number of low birth weight babies  N=total number of births

The expected IR will be the same for every observation: 
exp= Σ simlbw0105/ Σ simbir0105 = 73385/1201340
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To calculate the SIR for each region: 

Table-> Update column-> choose table to update, SIR, and table from -> type in value: (simlbw0105/simbir0105)/(73385/1201340) -> Click ‘OK’.
Calculating R2 values:

As extra credit, you have the option to calculate R2 values. This can be done in SAS, Excel, or many other programs.  To calculate R2 in Excel you will need export your data to a CSV so it can be used in Excel.

In Mapinfo go to Table->Export->talbot2 (whatever name you used)-> save file in .csv format (under drop-down menu)-> check the box for 'Use first line for column titles'-> click 'OK'
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Open Excel. File-> Open-> choose your .csv file (make sure to change file types to 
'text files *.prn, *.txt, *.csv') 

You will then calculate the R2 to measure the association between the fields SIR and prop_black or prop_pov.  Further instructions are provided in Appendix 4.
Exercise:

1. Make three choropleth maps of the low birth weight SIRs for the different scales of data and one choropleth map for race.  Categorize the data the same for each scale. Use at least 5 categories with the middle category being around the SIR of 1.  Use a divergent color scheme. If you have questions about divergent color schemes go to www.colorbrewer.org.

Make sure you include a legend in each map. Also make one choropleth map of the proportion of blacks for scale 3.  Include these 4 maps in lab write-up.

Scale 1:  SIR map of original data 1595 ZIP codes

Scale 2:  SIR map of aggregated areas with at least 300 births in each area.

Scale 3:  SIR map of aggregated areas with at least 600 births in each area.

Make a thematic map of the proportion of the population which is black for Scale 3 

2. We have calculated the (R2) for Scale 2 and Scale 3 between

Blacks/total population & low birth weight births SIRs


Scale 2 R2 = 0.493664


Scale 3 R2 = 0.603437
For extra credit, calculate the correlation (R2) between children living in poverty/ total children & the SIRs. 


Scale 2 R2      _________    


Scale 3 R2       _________


3. We measured the correlations at two different scales between either:

   proportion blacks  and the proportion of low birth weight births.




or

proportion children living in poverty and the proportion of low birth weight births.

The R2  are different at the two different scales. Why do you think the correlation increases with the level of aggregation?

This exercise is due on Thursday, April 16th,
not the due date on the syllabus .
Appendix 1

Contiguity Program

************************************************************

** program generate a (rook) contiguity file

**
SAS 9.1 under Windows XP

** program by Gwen LaSelva (gdb02@health.state.ny.us)

** Bureau of Environmental Health Surveillance

** Center for Environmental Health

** New York State Department of Health

** 

** August 21, 2008

************************************************************

** inputs: map in shapefile format.  

**  must have field 'id' which uniquely identifies each area.

************************************************************

** outputs: Sas data set which is a list of 

**

areas & their neighbors (rook contiguity)

************************************************************;

*note: uses hash tables, best run on a computer with generous amounts of memory;

libname cdisk "P:\Bureau\Project Docs\Lead\births\Final Data";

%let idvar=zip06; /*this is the unique identification variable from the map*/

%let outfile=zcont; /*this gives the output file name*/

/*edit to import your file of interest*/

proc mapimport


datafile="P:\Bureau\Project Docs\Lead\births\Final Data\zip06_simlbw2_region.shp"


out=mymap;

run;

/*are there duplicates? if so - must remove them*/

proc sort data=mymap out=mymap2 nodupkey; by x y &idvar.;run;

/*set up the data for the hash table

we want to use x & y as a key, but they are not unique

so add variable z such that x,y,z forms a unique key*/

data hashmap (keep=x y z &idvar.);

retain z;

set mymap2(where=(x NE . and y NE .));

/*there are some missing values*/

by x y;

if first.x or first.y then z=1;

z=z+1;

run;

/*determine the maximum value of z*/

proc means data=hashmap noprint;

output out=maxz max(z)=mz; run;

/*put the maximum value of z into macro variable maxnb*/

data _null_;

set maxz;

call symputx("maxnb",mz);

run;

/*for each point in the map, determine the id's of neighbors which 

also have the same point*/

proc sort data=mymap2; by &idvar.;run;

data nonb (keep=myid);

length x y z 8; format &idvar. $16.; /*use a format statement for character id values*/

if _n_=1 then do;


/*this hash table holds a second copy of the entire map for comparison*/


declare hash fc(dataset: "hashmap");


fc.definekey("x","y","z");


fc.definedata("x","y","z","&idvar.");


fc.definedone();


call missing (x,y,z,&idvar.);


/*this hash table will hold the rook neighbors for each area: they have two points in common*/


declare hash nb2(); 


nb2.definekey("&idvar.","myid");


nb2.definedata("&idvar.","myid");


nb2.definedone();

end;


/*this hash table holds the bishop neighbors for each area: they have a point in common*/


declare hash nb1(); 


nb1.definekey("&idvar.","myid");


nb1.definedata("&idvar.","myid");


nb1.definedone();

foundnb="N";

do until (last.myid);


set mymap2 (keep=&idvar. x y rename=(&idvar.=myid x=myx y=myy) where=(myx NE . and myy NE .)) end=eof;


by myid;



/*can't rename or messes up hash table. this seems goofy, what is SAS thinking?*/


do n=1 to &maxnb.; /*this is max number of points in common =max z*/

  

rc=fc.find(key:myx, key:myy, key:n);

  

if rc=0 and myid NE &idvar. then do; 




nbrc=nb1.check(key:&idvar, key:myid);




if nbrc=0 then do;






rc2=nb2.add(key:&idvar, key:myid, data:&idvar, data:myid);






foundnb="Y";




end;




else rc1=nb1.add(key:&idvar, key:myid, data:&idvar, data:myid);



end;


end;*do &maxnb.;

end;*end DOW loop;

if foundnb="N" then output nonb;

if eof then nb2.output(dataset:"cdisk.&outfile.");

run;

Appendix 2

Aggregation Program

*****************************************************************************************

*combine areas(zctas or zip codes) into regions

*programmed by Gwen Babcock July 2008

*modified January 2009 to use shapefile as source of data

*
and to work in SAS 9.2

*combined areas must meet certain criteria

* and stay within county boundaries

* this program uses hash tables, and will run best on a computer

* with generous amounts of memory

*********************************************************************

*Note: in comments, areas refer to the smaller geographic units which will be aggregated

*

regions refer to the larger aggregates which are created from the smaller geographic units

******************************************************************************************;

*inputs: 

*  contiguity file: for each zip code, lists contiguous zip codes

*

produced by SAS program "spatial contiguity shapefile.sas"

*  shapefile with: 

*

1.  coordinates of area centroids (in lat/lon decimal degrees) in variables 'latitude', 'longitude', 

*

2.  variable 'county' containing county FIPS or other unique character identifier of county

* 

3.  any other variables needed for merging criteria or mapping

*



such as population and number of cases

******************************************************************************************;

*outputs: 

*file with list of zip codes with the new region they are a part of, in dbf format

*
or SAS map

******************************************************************************************;

*provide contiguity file:;

%let confile=zcont;
/*contiguity file name, id variable is 'myid'*/

libname cdisk "P:\Bureau\Project Docs\Lead\births\Final Data"; /*library of contiguity file*/

/*contiguity file will be cdisk.&confile.*/

*provide other information:
;

%let idvar=zip06;  /*name of identifier variable of the areas*/

%let popvar=simbir0105 ; /*population variable, used for calculating population

weighted centroids.  If geographic centroids are desired, set equal to 1*/

%let criteriavar1=simbir0105;  /*first variable to base merging on*/

%let criteriavar2=simlbw0105; /*second variable to base merging on*/

%let mincriteria1=300;
/*merge until criteria variable is at least this*/

%let mincriteria2=0; /*merge until 2nd variable is at least this*/

%let dbfoutputfile=P:\Bureau\Project Docs\Lead\births\Final Data\simbirths300pw.dbf; /*output file for use in MapInfo, must end in *.dbf*/

/*import the map we wish to aggregate*/

/*it should have a county variable, centroid coordinates and the criteria variable*/

proc mapimport


datafile="P:\Bureau\Project Docs\Lead\births\Lab\zip06_simlbw2_region.shp"


out=zctas;

run;

/*turn the map into a list of areas with data*/

proc sort data=zctas out=zctas2 (rename=(&idvar=id) drop=x y segment) nodupkey ;by &idvar.; run;

/*first, get the contiguity table and arrange it so that each observation consists

of an area, a neighbor, and the sequential number of the neighbor.*/

proc sort data=cdisk.&confile; by myid;run;

/*add arbitrary sequential number to use as hash key later*/

data conblocklist (rename=(&idvar=neighbor myid=id));

set cdisk.&confile.;

by myid;

retain keyno;

keyno=sum(keyno,1);

if first.myid then keyno=1;

run;

/*find number of neighbors*/

proc means data=conblocklist noprint nway;

by id;

output out=numnb (drop=_:) max(keyno)=countnb;

run;

/*put number of neighbors in main dataset*/

data allblock (rename=(latitude=lat longitude=lon));

merge zctas2 numnb;

by id;

if countnb=. then countnb=0;

/*need to create a sort variable*/

if &criteriavar1.<&mincriteria1. or &criteriavar2.<&mincriteria2. then


priority=1;
/*these input areas need to be merged*/

else priority=2; /*these input areas do not need to be merged*/

run;

/*This is the main step of the program, where all the area

aggregation is done*/

*(keep=newregion &idvar. county &criteriavar1. &criteriavar2. countnb);

/*need to add popvar as separate variable?*/

data finalregions (keep= id newregion county zip06 simbir0105 simlbw0105 total0_4 AI_00_04 B_00_04 M_00_04 

W_00_04 PI_00_04 H_00_04 NH_00_04 lat lon hsg lths upov0_4 opov0_4 newregion &idvar. county &criteriavar1. &criteriavar2. countnb);

format id neighbor charreg newregion $9. county newcounty $15.; 

format dlat dlon lat lon lths hsg upov0_4 opov0_4 16.8;

if _n_=1 then do;


declare hash blist(dataset:'allblock'); /*this is a list of all areas with info by id*/


blist.definekey('id');


blist.definedata('id', "&criteriavar1.", "&criteriavar2.", 'county', 'lat', 'lon', 'countnb');


blist.definedone();


declare hash idregion();


idregion.definekey('id');


idregion.definedata('id','newregion');


idregion.definedone();


declare hash ord(dataset:'allblock', ordered: 'a');


ord.definekey('priority',"&criteriavar1." ,"&criteriavar2.", 'countnb','id');


ord.definedata('priority',"&criteriavar1.", "&criteriavar2." ,'countnb','id');


ord.definedone();


declare hash nb(dataset:'conblocklist'); /*this is the contiguity table, 104062 obs*/


nb.definekey('id', 'keyno'); /*must have unique key or values will be replaced*/


nb.definedata('id','keyno' ,'neighbor');


nb.definedone();


declare hiter rord('ord');


declare hiter ridregion('idregion');


declare hiter rblist('blist');


call missing(&criteriavar1., &criteriavar2., priority, lat, lon, countnb, id, neighbor, newregion, keyno); /*only need for missing vars*/

firstcases=0; region=0;
newcases=0;

do until (firstpriority=2);

/*initialize some values*/

rc=rord.first(); /*get initial values*/ 

region=region+1; charreg=left(put(region,8.));

rc=blist.find(key:id); /*get info about block/region to be merged*/

/*first, keep certain values from our block of interest*/

firstid=id;

firstcases=&criteriavar1.; firstpop=&criteriavar2.;

if &criteriavar1.<&mincriteria1. or &criteriavar2.<&mincriteria2. then


firstpriority=1;
/*these input areas need to be merged*/

else firstpriority=2; /*these input areas do not need to be merged*/

firstpopulation=&popvar.; 

firstcountnb=countnb; 

firstlat=lat; firstlon=lon; firstcounty=county;

/*for the block we need to merge, find a neighbor that meets our criteria*/

x=0;

do until(rcn NE 0);


x=x+1; 


if firstcountnb>0 then do;




rcn=nb.find(key:firstid,key: x); /*this gives us the id of the neighbor x*/




rc=blist.find(key:neighbor); /*get info about neighbor x*/


end;


else do; 



*putlog firstid " doesn't have contiguous neighbors";



if x>1 then rcn=rblist.next();



else if x=1 then rcn=rblist.first();



if id=firstid then rcn=rblist.next();/*can't be own neighbor*/



neighbor=id;


end;


if rcn=0 then do; /*if found a neighbor*/


/*calculate distance to this neighbor using Haversine formula


/*this is from http://www.movable-type.co.uk/scripts/latlong.html*/



*if firstid="10927" then put _all_;


/*SAS requries areguments of cos funciton to be in radians*/



dlat=(firstlat-lat)*constant('PI')/180; dlon=(firstlon-lon)*constant('PI')/180;



a=sin(dlat/2)*sin(dlat/2)+cos(lat*constant('PI')/180)*cos(firstlat*constant('PI')/180)*sin(dlon/2)*sin(dlon/2);



if a LE 0 or a GE 1 then put _all_;



c=2*atan2(sqrt(a),sqrt(1-a));



*if a=0 then put _all_;



distance=6371*c; /*6371 is the earth's radius in kilometers*/


/*if this is the first neighbor, take it unless we find a better one*/


if x=1 then do; 



nbid=neighbor; nbcounty=county; nbdist=distance; 


end;


/*a neighbor would be better if it were in the same county*/


if firstcounty NE nbcounty and firstcounty=county then do;



nbid=neighbor; nbcounty=county; nbdist=distance;


end;


/*or to be closer and in the same county*/


if firstcounty=nbcounty and firstcounty=county and distance<nbdist then do;



nbid=neighbor; nbcounty=county;  nbdist=distance;


end;


/*or just to be closer*/


if firstcounty NE nbcounty and firstcounty NE county and distance<nbdist then do;



nbid=neighbor; nbcounty=county; nbdist=distance;


end;


end; /*end if found neighbors*/

end; *cycle through neighbors;

rc=blist.find(key:nbid); /*get the selected neighbors info*/

/*put selected neighbor's info in variables*/

nbcount=countnb;

nbcases=&criteriavar1.;

nbpop=&criteriavar2.;

if &criteriavar1.<&mincriteria1. or &criteriavar2.<&mincriteria2. then


nbpriority=1;
/*these input areas need to be merged*/

else nbpriority=2; 

/*combine the info to get data about the new region*/

newcases=firstcases+&criteriavar1.;

newpop=firstpop+&criteriavar2.;

if newcases<&mincriteria1. or newpop<&mincriteria2. then


newpriority=1;
/*these input areas need to be merged*/

else newpriority=2;

/*population weighted geographic centriod of new area*/

/*check for areas with no population*/

if firstpopulation=0 or &popvar=0 then do;


firstpopulation=1; &popvar=1; /*do non-weighted centroid*/

end;


newlat=(firstlat*firstpopulation+lat*&popvar.)/(firstpopulation+&popvar.);


newlon=(firstlon*firstpopulation+lon*&popvar.)/(firstpopulation+&popvar.); 

/*if the new region is within a certain block grp, tract, or county assign it that block grp, tract, or county*/

newcounty=nbcounty; /*assign the new region to a county*/

*get the new count of neighbors of new region;

declare hash nl(); 

nl.definekey('id');

nl.definedata('id'); 

nl.definedone();

declare hiter rnl('nl');

*use hash table nl to hold list of neighbors to determine count;

do x=1 to sum(of firstcountnb,nbcount); 


rc1=nb.find(key:firstid, key:x);


if rc1=0 and (neighbor NE nbid) then rc=nl.add(key:neighbor, data:neighbor);


rc2=nb.find(key:nbid, key: x);


if rc2=0 and (neighbor NE firstid) then rc=nl.add(key: neighbor, data:neighbor); /*with add method, duplicate keys should be ignored*/

end;

newcountnb=nl.num_items;

/*add new data to blist and ord */

rc=blist.add(key:charreg, data:charreg, data:newcases, data: newpop, data:newcounty, data:newlat, data:newlon, data:newcountnb);

rc=ord.add(key:newpriority, key:newcases, key:newpop, key:newcountnb, key:charreg,



 data:newpriority, data:newcases, data:newpop, data:newcountnb, data:charreg);

/*remove old data from blist and ord*/

rc=blist.remove(key: firstid); rc=blist.remove(key: nbid);

/*first, delete iterator*/

rc=rord.delete();

rc=ord.remove( key:firstpriority, key:firstcases, key:firstpop,  key:firstcountnb, key:firstid);

rc=ord.remove( key: nbpriority, key:nbcases, key:nbpop, key:nbcount, key: nbid);

/*recreate iterator*/

rord=_new_ hiter('ord');

/*add the block or new region & its neighbor to new region table*/

rc=idregion.add(key:nbid, data: nbid, data:charreg);

rc=idregion.add(key:firstid, data:firstid, data:charreg);

************************************************************************************

*update the contignuity table*/

************************************************************************************;

/*for this, region must be character variable*/

/*add new conttable entries*/

do x=1 to newcountnb; /*add region with its list of neighbors*/


if x>1 then rc=rnl.next(); else rc=rnl.first();


rc=nb.add(key:charreg, key: x, data: charreg, data:x, data:id); regnbid=id;


/*update the neighbors so they show that they border the new region, not the old ones*/


rc=blist.find(key:regnbid); /*find countnb for this neighbor*/ rflag=0; z=0;


do y=1 to countnb;



rc=nb.find(key:regnbid, key:y);



if rc=0 then do; z=z+1;




if (neighbor=firstid or neighbor=nbid) and rflag=0 then do;





/*nb.replace(key:regnbid, key:y, data:regnbid, data:z, data:charreg); 





replace key with different gives funny results.  Try remove & add instead*/





rc=nb.remove(key:regnbid, key: y); rc=nb.remove(key:regnbid, key:z);





rc=nb.add(key:regnbid, key: z, data:regnbid, data:z, data: charreg);





rflag=rflag+1;





/*if a neighbor borders both joined objects, there will be a duplicate





and rflag will become 1 or more*/





end; 




else if (neighbor=firstid or neighbor=nbid) and rflag>0 then do; 






rc=nb.remove(key:regnbid, key:y); z=z-1;





end;




else if y NE z then do;





/*again, replacing with different key gives funny results- don't do it*/ 





*nb.replace(key:regnbid, key: y, data:regnbid, data:z, data:neighbor);





rc=nb.remove(key:regnbid, key: y); rc=nb.remove(key:regnbid, key: z);





rc=nb.add(key:regnbid, key:z, data:regnbid, data: z, data:neighbor);




end;




*if y>z then rc=nb.remove(key:regnbid, key:y); /*remove extra obs?*/



end; *if rc=0 that is, if we find regions's neighbor's neighbor;


end; *cycle through all neighbor's neighbors;


/*update the number of neighbors for the neighbors; will only change if the neighbor borders both joined objects*/


rc=blist.find(key:regnbid);


if countnb NE z then do; /*need to update both for ord and blist*/



rc=blist.replace(key:regnbid, data:regnbid, data: &criteriavar1., data:&criteriavar2., data:county, data:lat, data:lon, data:z);



rc=rord.delete();



if &criteriavar1.<&mincriteria1. or &criteriavar2.<&mincriteria2. then




priority=1;
else priority=2; 



rc=ord.remove(key:priority, key:&criteriavar1., key:&criteriavar2., key:countnb, key:id);



rc=ord.add( key:priority, key:&criteriavar1., key:&criteriavar2., key:z, key:id,





data:priority, data:&criteriavar1., data:&criteriavar2., data:z, data:id);



rord= _new_ hiter('ord');


end;

end; /*go through all neighbors*/

/*last, remove old regions which were joined from contiguity table*/


do x=1 to max(firstcountnb, nbcount);



rc1=nb.remove(key:firstid, key:x);



rc2=nb.remove(key:nbid, key: x);


end; *cycle through all old regions;

*****************************************************************************

*end update of contiguity table

*****************************************************************************;

end; *do until firstcases GE &mincriteria1. and firstpop GE &mincriteria2.;

rc=nb.delete();

rc=ord.delete();

rc=blist.delete();

rc=nl.delete();

end; *if _n_=1 - first run through;

/*match each block with the final region it was assigned*/

set allblock end=eof;

&idvar.=id; newregion=id; /*default is that block is unmerged*/

do until (rc NE 0);


rc=idregion.find(key:newregion);

end;

if  eof=1 then rc=idregion.delete();

run;

/*export the data to MapInfo so it can be mapped*/

filename join "&dbfoutputfile.";

proc dbf data=finalregions db4=join ;

format lat lon lths hsg upov0_4 opov0_4 16.8;

run;

*(keep= id newregion county zip06 simbir0105 simlbw0105 _00_0 AI_00_04 B_00_04 M_00_04 

W_00_04 PI_00_04 H_00_04 NH_00_04 lat lon hsg lths upov0_4 opov0_4) ;

/*or map the data in SAS*/

/*first, add region ids to original map*/

proc sort data=finalregions; by &idvar.;run;

proc sort data=zctas;by &idvar.; run;

data step1map;

merge finalregions (keep=&idvar. newregion)zctas; 

by &idvar.;run;

proc sort data=step1map; by newregion;run;

/*proc gremove joins the areas into regions*/

proc gremove data=step1map out=finalmap;

by newregion;

id &idvar.;

run; /*a few seconds for zip codes*/

/*summarize the data by region to map it*/

proc means data=finalregions noprint;

class newregion;

output out=finalmapdata sum(&criteriavar1. &criteriavar2.)=&criteriavar1. &criteriavar2.;

run;

proc freq data=finalmapdata;

table &criteriavar1. &criteriavar2.;

run;

/*create a chloropleth map of the new regions shaded by your variable*/

proc gmap map=finalmap data=finalmapdata;

id newregion;

choro &criteriavar1.;

choro &criteriavar2.;

run;quit;

Appendix 3
2001-2005 New York State Low Birth Weight Simulated Dataset
Description of Sources, Data Dictionary, and Methods

How we simulated the data:
We acquired NYS low birth weight data at the zip code level and (to protect confidentiality) simulated the number of total births and number of low birth weight babies using a binomial distribution. 

How population data was added:
Education and poverty data was added to block points from block groups. Proportions of high school graduates and children <5 living under poverty from block groups were multiplied by the population of children <5 assigned to each block point. Race and ethnicity data were assigned to each block point from the census SF1 files. We spatially joined the simulated zip code LBW data with census block points to add SF1 data fields for race and ethnicity. Block points were assigned zip codes based on whether or not the point was contained within the zip code polygon.

Age range used:
We used census 2000 population data for children less than 5 years of age to simulate the population of births from 2001-2005.

The dataset contains 20 Fields:

Field 
Description 
ZIP061
 2006 ZIP Codes 
county2 
County containing ZIP
Latitude 
Latitude for population-weighted ZIP Centroid
Longitude 
Longitude for population-weighted ZIP Centroid
simbir01053 
Simulated N total births for ZIP 2001-2005
simlbw01053 
Simulated N low birth weight babies born for ZIP 2001-2005
W_00_044 
Single race white population <5 years in ZIP 
B_00_044 
Single race black population <5 years in ZIP 
AI_00_044
Single race American Indian population <5 years in ZIP 
A_00_044 
Single race Asian population <5 years in ZIP 
PI_00_044 
Single race Pacific Islander population <5 years in ZIP 
O_00_044 
Single race Other population <5 years in ZIP 
M_00_044 
Multiple race population <5 years in ZIP 
H_00_044 
Hispanic ethnicity population <5 years in ZIP 
NH_00_044 
Non-Hispanic ethnicity population <5 years in ZIP 
total0_44 
Total population <5 years in ZIP 
UPov_LT5_years_old5 
N population <5 years living under poverty level
OPov_LT5_years_old5 
N population <5 years living at or above poverty level
lths5 
N population >25 years with less than high school education
hsg5 
N population >25 years with high school + education

Data Sources:
1 2006 Zip Codes, 2 NYSDOH County File, 3 NYS LBW data Vital Statistics,  4 2000 Census SF1 File, 5 2000 Census SF3 File

Appendix 4

Measuring Correlations in Excel – Measuring the association (R2) between low birth weight SIRs and either proportion of the population which is black or the proportion of the children living in poverty is easy in Excel. You can use MapInfo to export your table as a CSV file (Table->Export).  You can then calculate the R2 using the RSQ function in Excel. Here is an example. 

	RSQ 
	

	
Hide All
Returns the square of the Pearson product moment correlation coefficient through data points in known_y's and known_x's. For more information, see PEARSON. The r-squared value can be interpreted as the proportion of the variance in y attributable to the variance in x.

Syntax

RSQ(known_y's,known_x's)

Known_y's   is an array or range of data points.

Known_x's   is an array or range of data points.

Remarks

· Arguments can either be numbers or names, arrays, or references that contain numbers. Logical values and text representations of numbers that you type directly into the list of arguments are counted. If an array or reference argument contains text, logical values, or empty cells, those values are ignored; however, cells with the value zero are included. Arguments that are error values or text that cannot be translated into numbers cause errors. If known_y's and known_x's are empty or have a different number of data points, RSQ returns the #N/A error value. If known_y's and known_x's contain only 1 data point, RSQ returns the #DIV/0! error value.

· The equation for the Pearson product moment correlation coefficient, r, is: [image: image9.png]



where x and y are the sample means AVERAGE(known_x’s) and AVERAGE(known_y’s).

RSQ returns r2, which is the square of this correlation coefficient.

Example

The example may be easier to understand if you copy it to a blank worksheet.
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	A

B

Known y

Known x

2

6

3

5

9

11

1

7

8

5

7

4

5

4

Formula

Description (Result)

=RSQ(A2:A8,B2:B8)

Square of the Pearson product moment correlation coefficient through data points above (0.05795)
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